Knowledge Library
Knowledge Library Home
Knowledge Library Home Knowledge Library Products Operating Systems Wind River Linux Wind River Linux 8 User Space Development LIN8-10007 : Security Advisory - gettext - CVE-2018-18751

LIN8-10007 : Security Advisory - gettext - CVE-2018-18751

Table of contents
Defect #: LIN8-10007
Found In Version8.0.0.28
Fix Version8.0.0.28
Severity:Standard
Status:Fixed
Created Date:10/31/2018
Component/s :Userspace
Sub Component:gettext

Description

An issue was discovered in GNU gettext 0.19.8. There is a double free in default_add_message in read-catalog.c, related to an invalid free in po_gram_parse in po-gram-gen.y, as demonstrated by lt-msgfmt.

https://nvd.nist.gov/vuln/detail/CVE-2018-18751

Downloads


KLID_DEFECT (use as Content ID for linking):  KLID_DEFECT_58093
 
Last modified