Knowledge Library
Knowledge Library Home
Knowledge Library Home Knowledge Library Installation & Licensing Installation INSTSUITE-6013 : The WRLinux7 installer crashes with a cario assertion error on CentOS 6.5

Learn more about page titles
INSTSUITE-6013 : The WRLinux7 installer crashes with a cario assertion error on CentOS 6.5

Defect #: INSTSUITE-6013
Previous IDLIN7-2449
Found In Version2.6.3
Fix Version2.7
Severity:Standard
Status:Fixed
Created Date:12/15/2014
Component/s :Suite Installer
Host OS:Linux 64

Description

When installing WRLinux 7 on a CentOS 6.5 x86_64 host, which was "updated" after November 2014, the installer crashes with the error after selecting Next in the Preconditions dialog:

java: cairo-misc.c:380: _cairo_operator_bounded_by_source: Assertion `NOT_REACHED' failed.

Workaround

Run 
./setup_linux -vmargs -Dorg.eclipse.swt.internal.gtk.cairoGraphics=false

as per https://www.eclipse.org/forums/index.php/t/834565/

Steps to Reproduce

1. Log in to a CentOS 6.5 host which was updated with "yum update" in December 2014 or later
2. Download the WRLinux-7 Installer from Windshare and extract it
3. ./setup_linux
4. Walk through the installer using default options
--> The installer crashes after entering WindShare credentials (before accepting the license).

KLID_DEFECT (use as Content ID for linking):  KLID_DEFECT_31468
 
Last modified